Parallel Computing in the Computer Science Curriculum > Workshops > SIGCSE 2012 Workshop 34 > Software Needed

SIGCSE '12 Workshop 34: Software You will Need

Operating System

Any relatively recent operating system should suffice, including:
Windows: XP, Vista, 7
Mac: OS X
Linux: Ubuntu or any other flavor

Browser

Any browser should suffice for viewing the workshop we pages

Text Editor

Please have an editor capable of producing plain ASCII text files of C or C++ code. You may prefer one that has color coding of source code. You will also likely want to have an IDE for Java development such as Eclipse.

SSH Clients

For remote login and file transfer you will require an SSH client.

Windows suggestions: PuTTY and WinSCP
Mac: Existing Terminal commands ssh and scp will be fine; nothing needed
Linux: Existing Terminal commands ssh and scp will be fine; nothing needed